Welcome Guest. ( logon | register )   
FAQ Member List Albums Today's Posts Search

PointedThree :  Vans, Trucks, SUVs and Other Forums : G-Class : Fuel Pump Relay?

Page 1 of 1 1
Fuel Pump Relay?
Topic Tools Message Format
Author
Posted 8/12/2019 3:25 PM
DUTCH
Administrator Doppelgänger




Date registered: Apr 2006
Location: US, GA, Atlanta
Vehicle(s): 2000 G500 NMLE, 2015 Audi Q7 3.0 TDI
Posts: 9785
5000
Fuel Pump Relay?

Does anyone have any thoughts or recommendations on this request from a member in another country?

I still have my green 2000 MB (Puch) G500 Cabriolet. I don't know if you can help me. After 12 years of owning my G, yesterday was the first time it "let me in the street" . When for jogging, when finish started the car drive for 5 minutes and it went off (dead) had all lights on panel, had ignition, started, but did not start, after 5 minutes, tried again, it DID start and arrive home. My diagnosis is Fuel Pump relay, because the fuel pump is new 50,000 Kilometers (31,250 Miles)., The problem is, that I can not find the location of the relay, have no manual that say's so , not even the fuse and relay chart, no one knows in the USA because my G is European version, 2 door Convertible,. etc. Can you give a clue were to look for or if somebody has a diagram for a 2000 4632061X.... Thank you


Any chance this could be a bad CPS or K40 Relay?
#240877
Top of the page Bottom of the page
Author
Posted 8/12/2019 9:21 PM
J.R.
Elite Veteran




Date registered: Apr 2006
Location: Southern Maryland
Vehicle(s): 00 G500, 09 911 4S, 11 Cayenne S, 86 280GE (sold)
Posts: 750
500
RE: Fuel Pump Relay?

My first place to check would be the k40 relay's solder joints.

However, preventive maintenance says to replace both and see if the K40 can be resoldered.

#240882 - in reply to #240877
Top of the page Bottom of the page
Author
Posted 8/13/2019 6:55 AM
DUTCH
Administrator Doppelgänger




Date registered: Apr 2006
Location: US, GA, Atlanta
Vehicle(s): 2000 G500 NMLE, 2015 Audi Q7 3.0 TDI
Posts: 9785
5000
RE: Fuel Pump Relay?

J.R. - 8/12/2019 9:21 PM

My first place to check would be the k40 relay's solder joints.

However, preventive maintenance says to replace both and see if the K40 can be resoldered.



My thoughts, too. Thanks!
#240885 - in reply to #240882
Top of the page Bottom of the page
Author
Posted 8/13/2019 12:24 PM
otiswesty
Expert




Date registered: Jun 2007
Location: Portland, Oregon
Vehicle(s): G500
Posts: 2693
2000
Re: Fuel Pump Relay?

That must be Freddy with the bright green Cab
I agree the K40 is the likely culprit, I carry a spare for that reason. It would be good idea to alsodo the CPS as you mentioned.
#240886 - in reply to #240885
Top of the page Bottom of the page
Author
Posted 8/17/2019 4:55 AM
David J. Pearson
Regular




Date registered: Apr 2006
Location: Cumbria, UK
Vehicle(s): 230 GES,G500 Classic,300TE 24, 200 CLK Cab. 73 TR6
Posts: 86
50
Re: Fuel Pump Relay?

Had exactly this problem last year. Couldn't trace or replicate the problem at shop as would start every time for them, but thought it was fuel pump. Fitted new one, four or five months later, exactly the same problem. Fitting spare k40 fixed it. Ordered new one and been ok ever since.


Edited by David J. Pearson 8/17/2019 5:01 AM
#240907 - in reply to #240882
Top of the page Bottom of the page
« View previous thread :: View next thread »
Page 1 of 1 1
Forum Jump :
All times are EST.  The time is now 10:23:36 PM.

Execution: 0.421 seconds, 95 cached, 9 executed.